bitbake toolchain error

Forum Forums System-on-Module bitbake toolchain error

This topic contains 5 replies, has 2 voices, and was last updated by  alexlin_1 5 months, 1 week ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #381

    alexlin_1
    Participant

    bitbake meta-toolchain or bitbake meta-toolchain-qt5 also error,

    ERROR: gcc-crosssdk-initial-x86_64-pokysdk-linux-7.3.0-r0 do_configure: Function failed: do_configure (log file is located at /root/imx-yocto-bsp/build_fsl-image-qt5-validation-imx/tmp/work/x86_64-linux/gcc-crosssdk-initial-x86_64-pokysdk-linux/7.3.0-r0/temp/log.do_configure.23433)
    ERROR: Logfile of failure stored in: /root/imx-yocto-bsp/build_fsl-image-qt5-validation-imx/tmp/work/x86_64-linux/gcc-crosssdk-initial-x86_64-pokysdk-linux/7.3.0-r0/temp/log.do_configure.23433

    log.do_configure.23433:
    cat: /root/imx-yocto-bsp/build_fsl-image-qt5-validation-imx/tmp/work-shared/gcc-7.3.0-r0/gcc-7.3.0/gcc/defaults.h: No such file or directory

    why i have no this files??how to fix it?

    • This topic was modified 5 months, 1 week ago by  alexlin_1.
    #383

    alexlin_1
    Participant

    ERROR: Task (/root/imx-yocto-bsp/sources/poky/meta/recipes-devtools/gcc/gcc-crosssdk-initial_7.3.bb:do_configure) failed with exit code ‘1’

    #385

    lion.wang
    Keymaster

    Hi Alex,

    Do you follow WIBO-iMX8MQ-Yocto_Project_User’s_Guide steps?
    We do not have this problem.

    #386

    alexlin_1
    Participant

    yes

    #387

    lion.wang
    Keymaster

    It seems some file do not auto generate.
    Could you check packages list in below are all install?

    $ sudo apt-get install gawk wget git-core
    $ sudo apt-get install diffstat unzip texinfo
    $ sudo apt-get install gcc-multilib build-essential
    $ sudo apt-get install chrpath socat libsdl1.2-dev

    $ sudo apt-get install xterm sed cvs subversion
    $ sudo apt-get install coreutils texi2html docbook-utils
    $ sudo apt-get install python-pysqlite2 help2man make gcc g++
    $ sudo apt-get install desktop-file-utils libgl1-mesa-dev
    $ sudo apt-get install libglu1-mesa-dev mercurial autoconf automake
    $ sudo apt-get install groff curl lzop asciidoc
    $ sudo apt-get install u-boot-tools g++-multilib

    #388

    alexlin_1
    Participant

    after repo sync, bitbake toolchain is OK!

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.