sd card booting error

Forum Forums System-on-Module sd card booting error

This topic contains 11 replies, has 2 voices, and was last updated by  alexlin_1 7 months ago.

Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
    Posts
  • #384

    alexlin_1
    Participant

    U-Boot 2017.03-imx_v2017.03_4.9.88_2.0.0_ga+gb76bb1bf9f (Mar 12 2019 – 13:44:12 +0800)

    CPU: Freescale i.MX8MQ rev2.0 1500 MHz (running at 1000 MHz)
    CPU: Commercial temperature grade (0C to 95C) at 25C
    Reset cause: POR
    Model: InnoComm i.MX8MQ Wibo board
    I2C: ready
    DRAM: 2 GiB
    MMC: FSL_SDHC: 0, FSL_SDHC: 1
    *** Warning – bad CRC, using default environment

    In: serial
    Out: serial
    Err: serial

    BuildInfo:
    – ATF 6a83ae0
    – U-Boot 2017.03-imx_v2017.03_4.9.88_2.0.0_ga+gb76bb1bf9f

    switch to partitions #0, OK
    mmc1 is current device
    Net:
    Warning: ethernet@30be0000 using MAC address from ROM
    eth0: ethernet@30be0000
    Normal Boot
    Hit any key to stop autoboot: 0
    switch to partitions #0, OK
    mmc1 is current device
    reading boot.scr
    ** Unable to read file boot.scr **
    reading Image
    20060672 bytes read in 873 ms (21.9 MiB/s)
    Booting from mmc …
    reading wibo-imx8mq.dtb
    ** Unable to read file wibo-imx8mq.dtb **
    WARN: Cannot load the DT
    u-boot=>

    the sdcard have no wibo-imx8mq.dtb???
    where is this?

    #389

    lion.wang
    Keymaster

    Hi Alex,

    You can reference WIBO-iMX8MQ-Yocto_Project_Quick_Start_Guide.pdf from page 22 to page 28.
    There are more detail information to show you how to flash image to SD card.

    #390

    alexlin_1
    Participant

    Hi, Lion,

    it can’t use decompress the *.sdcrad.bz2?? and can’t use dd command??

    #391

    lion.wang
    Keymaster

    Hi Alex,

    Please reference WIBO-iMX8MQ-Yocto_Project_Quick_Start_Guide.pdf from page 22 to page 28.
    You should use mfgtools to flash firmware.

    #392

    alexlin_1
    Participant

    Hi Lion,

    ok, i will try,
    when i bitbake all system, i had seen that have opencv package install, but when i bitbake meta-toolchain, finialy i can’t see #include <opencv2/opencv.hpp> , how can i build the environment and use toolchain to compiler opencv code??

    #393

    lion.wang
    Keymaster

    Hi Alex,

    Sorry,I am not familiar with Yocto system.
    You can reference answer in below. I think it can solve your problem.
    https://community.nxp.com/thread/315091

    #394

    alexlin_1
    Participant

    hi Lion,

    I had seen that page,but core-image-x11 , imx8m not support.

    #395

    lion.wang
    Keymaster

    Hi Alex,

    Maybe you can try to use Wayland.
    It’s support on imx8m.

    #396

    alexlin_1
    Participant

    Hi lion,
    sdcard is ok!
    now the question is OPENCV environment, follow your webpage its for imx6, now i try wayland, don’t have any idea to build the environment, any command?

    Alex

    #397

    lion.wang
    Keymaster

    Hi Alex,

    Sorry,I am not familiar with Yocto system.

    #398

    alexlin_1
    Participant

    Hi lion,

    could you ask the vender?
    send me your wechat info to my mail.

    Alex

    #399

    alexlin_1
    Participant

    hi lion,

    opencv environment is ok, tks!

    Alex

Viewing 12 posts - 1 through 12 (of 12 total)

You must be logged in to reply to this topic.